nyoj288Time

Time

时间限制:1000 ms  |  内存限制:65535 KB

难度:2

输入

There are several test cases.
Each case contains 4 integers in a line, separated by space.
Proceed to the end of file.

输出

For each test case, output the time expressed by the digital clock such as Sample Output.

样例输入

1 2 5 6
2 3 4 2

样例输出

    _  _  _ 
  | _||_ |_ 
  ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 

描述

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

 

Hint:

 

The digits showed by the digital clock are as follows:

   _  _     _  _  _  _  _  _ 
 | _| _||_||_ |_   ||_||_|| |
 ||_  _|  | _||_|  ||_| _||_|

初见本题,想的思路是编写一个函数,其中传递一个参数,然后再函数中进行打印,最后感觉行不通,就算做出来了也是相当的复杂,在讨论区看见一种非常妙哉的方法。不过没有解释,写下个人理解,供大家参考和指教,我个人的理解是:将所有的数字先写出来,你就会发现每个拆分是最好的选择,然后创建一个二维数组,对每个数字的形状再数组中进行拆分,也就是三行,没有的地方就用空格代替。

#include<cstdio>
#include<string>
#include<iostream>
using namespace std;

string s[10][3] = {{" _ ","| |","|_|"},{" ", " |", " |"},{" _ ", " _|", "|_ "},{" _ ", " _|", " _|"},{" ", "|_|", " |"},
{" _ ", "|_ ", " _|"},{" _ ", "|_ ", "|_|"},{" _ ", " |", " |"},{" _ ", "|_|", "|_|"},{" _ ", "|_|", " _|"}};

int main() {
int a, b, c, d;
while (~scanf("%d%d%d%d", &a, &b, &c, &d)) {
for (int i = 0; i < 3; i++) {
cout << s[a][i] << s[b][i] << s[c][i] << s[d][i] << endl; 
}
}
return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值