hdu-1711 kmp算法学习

看了两篇博客

字符串匹配的KMP算法

【经典算法】——KMP,深入讲解next数组的求解

相关题目:poj2406;poj3461;poj2752
以下为例题:(Number Sequence HDU - 1711

要求:

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input:

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output:

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input:

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output:

6
-1

分析:

其实没啥可分析的,题目大意很好理解,就是给两个大的数组让你匹配,kmp算法上面两篇博客讲的很清楚了,有个细节,kmp算法返回值为数组元素的下标,而该题要求为元素的位置,那么再加一即可,以下为ac代码:

#include <cstdio>
#include <cstring>
using namespace std;
int a[1000005], b[10005];
int next[10005];
int N, M;
void get_next() {
	int k = 0, i = 0;
	next[0] = 0;
	for (i = 1;i < M;i++) {
		while (k > 0 && b[i] != b[k])
			k = next[k - 1];
		if (b[i] == b[k])
			k++;
		next[i] = k;
	}
}
int kmp() {
	int k = 0, i;
	get_next();
	for (i = 0;i < N;i++) {
		while (k > 0 && a[i] != b[k]) { k = next[k - 1]; }
		if (a[i] == b[k])
			k++;
		if (k == M)return i - k + 2;
	}
	return -1;
}
int main()
{
	int T;
	scanf("%d", &T);
	while (T--) {
		memset(a, 0, sizeof(a));
		memset(b, 0, sizeof(b));
		memset(next, 0, sizeof(next));
		scanf("%d%d", &N, &M);
		for (int i = 0;i < N;i++)scanf("%d", a + i);
		for (int j = 0;j < M;j++)scanf("%d", b + j);
		printf("%d\n", kmp());
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值