【CodeForces 1251B --- Binary Palindromes】

【CodeForces 1251B --- Binary Palindromes】


Description

A palindrome is a string t which reads the same backward as forward (formally, t[i]=t[|t|+1−i] for all i∈[1,|t|]). Here |t| denotes the length of a string t. For example, the strings 010, 1001 and 0 are palindromes.

You have n binary strings s1,s2,…,sn (each si consists of zeroes and/or ones). You can swap any pair of characters any number of times (possibly, zero). Characters can be either from the same string or from different strings — there are no restrictions.

Formally, in one move you:

  • choose four integer numbers x,a,y,b such that 1≤x,y≤n and 1≤a≤|sx| and 1≤b≤|sy| (where x and y are string indices and a and b are positions in strings sx and sy respectively),
  • swap (exchange) the characters sx[a] and sy[b].

What is the maximum number of strings you can make palindromic simultaneously?

Input

The first line contains single integer Q (1≤Q≤50) — the number of test cases.

The first line on each test case contains single integer n (1≤n≤50) — the number of binary strings you have.

Next n lines contains binary strings s1,s2,…,sn — one per line. It’s guaranteed that 1≤|si|≤50 and all strings constist of zeroes and/or ones.

Output

Print Q integers — one per test case. The i-th integer should be the maximum number of palindromic strings you can achieve simultaneously performing zero or more swaps on strings from the i-th test case.

Sample Input

4
1
0
3
1110
100110
010101
2
11111
000001
2
001
11100111

Sample Output

1
2
2
2

Note

In the first test case, s1 is palindrome, so the answer is 1.

In the second test case you can’t make all three strings palindromic at the same time, but you can make any pair of strings palindromic. For example, let’s make s1=0110, s2=111111 and s3=010000.

In the third test case we can make both strings palindromic. For example, s1=11011 and s2=100001.

In the last test case s2 is palindrome and you can make s1 palindrome, for example, by swapping s1[2] and s1[3].

解题思路:

能够出现不对称的情况只有一种:字符串中有奇数个1和奇数个0;
但是如果出现奇数长度的字符串后就可以去掉不对称的情况。
所以我们只需要判断没有奇数长度的字符串以及1的个数和0的个数都为奇数就行了。

AC代码:

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;
#define SIS std::ios::sync_with_stdio(false)

int main()
{
    SIS;
    string s;
    int T;
    cin >> T;
    while(T--)
    {
        int n,arr[2];
        bool flag=false;
        arr[0]=arr[1]=0;
        cin >> n;
        for(int i=0;i<n;i++)
        {
            cin >> s;
            int len=s.size();
            if(len&1) flag=true;
            for(int j=0;j<len;j++)
                arr[s[j]-'0']++;
        }
        if(arr[0]&1 && arr[1]&1 && !flag) n--;
        cout << n << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值