find a way

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

Input

The input contains multiple test cases. 
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character. 
‘Y’ express yifenfei initial position. 
‘M’    express Merceki initial position. 
‘#’ forbid road; 
‘.’ Road. 
‘@’ KCF 

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M

4 4
Y.#@
....
.#..
@#.M
5 5

Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

解题思路:这题用到队列+bfs,本来想用dfs递归做的,后来发现dfs无法记录Y和M行走的步数

vis数组记录走过的路径,防止走重复的路

      int min=999999;
        for(int i=0; i<num; i++)
        {
            if(a[i]==-1)
                continue;
            min=(min>a[i]+1)?a[i]+1:min;
        }

这段代码的意思是用a数组记录每个@位置所需要走的步数,当a[i]==1是,表示该@无法到达,然后通过与min的比较

出最小的步数,结果乘11就是答案了

 

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
    int x, y, step;
};
int map[200][200],vis[200][200],a[50000];
int m,n,_xy[4][2]= {{-1,0},{1,0},{0,1},{0,-1}};
queue<node>q;
int judge(int x,int y)
{
    if(x<0||x>m||y<0||y>n)
        return 1;
    else if(map[x][y]==-1||vis[x][y]==1)
        return 1;
    return 0;
}
void bfs(int x1,int y1)
{
    memset(vis,0,sizeof(vis));
    node first,next;
    first.x=x1;
    first.y=y1;
    first.step=0;
    q.push(first);
    while(!q.empty())
    {
        first=q.front();
        q.pop();
        a[map[first.x][first.y]]+=first.step;
        for(int i=0; i<4; i++)
        {
            next.x=first.x+_xy[i][0];
            next.y=first.y+_xy[i][1];
            if(judge(next.x,next.y))
                continue;
            next.step=first.step+1;
            vis[next.x][next.y]=1;
            q.push(next);
        }
    }
}
int main()
{
    int Y_x,Y_y,M_x,M_y;
    char c;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(a,-1,sizeof(a));
        int num=1;
        for(int i=1; i<=m; i++)
        {
            for(int j=1; j<=n; j++)
            {
                cin>>c;
                if(c=='#')
                    map[i][j]=-1;
                else if(c=='Y')
                {
                    Y_x=i;
                    Y_y=j;
                    map[i][j]=0;
                }
                else if(c=='M')
                {
                    M_x=i;
                    M_y=j;
                    map[i][j]=0;
                }
                else if(c=='@')
                    map[i][j]=num++;
                else
                    map[i][j]=0;
            }
        }
        bfs(Y_x,Y_y);
        bfs(M_x,M_y);
        int min=999999;
        for(int i=0; i<num; i++)
        {
            if(a[i]==-1)
                continue;
            min=(min>a[i]+1)?a[i]+1:min;
        }
        printf("%d\n",min*11);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值