杭电OJ | 1092、1093、1094、1096以及scanf的小白之坑

笔记:

1. 要记得while(0)是不执行循环啊!

while(scanf("%d",&a)!=EOF && a);     //只要a不是0,就执行循环体中的代码

2. scanf的返回值:scanf函数返回成功读入的数据项数

scanf(“%d”,&a)!=0     //scanf(“%d”,&a) 成功输入则为1,未输入则为0

所以这个语句并不是用来判断输入是否为 0

1092

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

Sample Input

4 1 2 3 4 5

1 2 3 4 5

0

Sample Output

10

15

#include <stdio.h>

int main(){
    int inputnum=0;
    while((scanf("%d",&inputnum)!=EOF)&&(inputnum!=0)){
//    while((scanf("%d",&inputnum))!=EOF&&inputnum){     //或者这样写
        int sum = 0;
        for(;inputnum!=0;inputnum--){
            int a;
            scanf("%d",&a);
            sum=sum+a;
        }
        printf("%d\n",sum);
        }
    return 0;
}

1093

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

Sample Input

2

4 1 2 3 4

5 1 2 3 4 5

Sample Output

10

15

#include <stdio.h>

int main(){
    int groupnum;
    scanf("%d",&groupnum);
    while(groupnum!=0){
        int inputnum;
        scanf("%d",&inputnum);
    	int sum = 0; 
    	for(;inputnum!=0;inputnum--){
            int a;
            scanf("%d",&a);
            sum=sum+a;
        }
	printf("%d\n",sum);
	groupnum--;
	}
    return 0;
}

1094

Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line. 

Output

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input. 

Sample Input

4 1 2 3 4

5 1 2 3 4 5

Sample Output

10

15

#include <stdio.h>

int main(){
    int inputnum;
    while(scanf("%d",&inputnum)!=EOF){
    	int sum = 0; 
    	for(;inputnum!=0;inputnum--){
			int a;
			scanf("%d",&a);
			sum=sum+a;
		}
	    printf("this %d\n",sum);
	}
    return 0;
}

1096

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3

Sample Output

10\n

15\n

6

要点:最后一个结果换一个行,此外的结果换两个行...

#include <stdio.h>

int main(){
    int groupnum;
    scanf("%d",&groupnum);
    while(groupnum!=0){
        int inputnum;
        scanf("%d",&inputnum);
    	int sum = 0; 
    	for(;inputnum!=0;inputnum--){
            int a;
            scanf("%d",&a);
            sum=sum+a;
        }
        //注意换行要求
        if(groupnum==1){
    	    printf("%d\n",sum);
        }
        else{
            printf("%d\n\n",sum);
        }
	groupnum--;
	}
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值