杭电OJ | 1170 一定要记得getchar吸收换行符!

1170

Input         Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator. 

Output       For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input

4

+ 1 2

- 1 2

* 1 2

/ 1 2

Sample Output

3

-1

2

0.50

要点:注意输出和getchar吸收换行!!!再忘记getchar我就!再学一遍...

#include <stdio.h>
int main(){
	int inputnum;
	scanf("%d",&inputnum);
	getchar();
	for(;inputnum!=0;inputnum--){
		int a,b;
		char c;
		scanf("%c %d %d",&c,&a,&b);
		getchar();
		if(c=='+'){
			printf("%d\n",a+b);
		}
		else if(c=='-'){
			printf("%d\n",a-b);
		}
		else if(c=='*'){
			printf("%d\n",a*b);
		}
		else{
			if(a%b==0){
				printf("%d\n",a/b);
			}
			else{
				printf("%.2f\n",1.0*a/b);
			}
		}
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值