拆数字(qduoj)

拆数字

Description

 

输入多行正整数,输入他们拆分后的形式,比如 1234拆分为1 1000 + 2 100 + 3 10 + 4 1,1034拆分为 1 1000 + 3 10 + 4 * 1

Input

 

多行正整数

Output

 

对应的拆分结果,乘号使用 * 代替,数字和符号之间都有一个空格间隔

Sample Input 1 

1234
1034

Sample Output 1

1 * 1000 + 2 * 100 + 3 * 10 + 4 * 1
1 * 1000 + 3 * 10 + 4 * 1
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int main(){
char a[15];
  while(~scanf("%s",a)){
  int x=strlen(a);
    cout<<a[0]<<" * "<<(int)pow(10,x-1);
    for(int i=1;i<x;i++){
    if(a[i]=='0') continue;
      cout<<" + "<<a[i]<<" * "<<(int)pow(10,x-i-1);
    }
  cout<<endl;
  }
return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值