Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

题意:n行,m列,*代表土地,@代表油田,可以连通的油田里面是同一种油,问一共有几种不同的油?注意,油田的连通方向是八个方向;

思路:用二维数组存图,在遍历图的过程中,发现@计数器加一,然后以发现的@的x与y坐标开始深搜,在深搜过程中,只要搜到@就把他变成*,这样与计数器加一有关的@以及相关联的@都变成了*,这就发现了完整的一块油田,最后输出计数器的值就行了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int n,m;
int ans;
char mp[105][105];
int pos[8][2]= {{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
void dfs(int x,int y) {
	int i;
	mp[x][y]='*';//搜完就记为*
	int tx,ty;
	for(i=0; i<8; i++) {
		tx=x+pos[i][0];
		ty=y+pos[i][1];
		if(tx>-1&&tx<n&&ty>-1&&ty<m) {
			if(mp[tx][ty]=='@')
				dfs(tx,ty);
		}
	}
}
int main() {
	while(scanf("%d%d",&n,&m)!=EOF) {
		if(n==0&&m==0)break;
		int i,j;
		for(i=0; i<n; i++) {
			scanf("%s",mp[i]);
			getchar();
		}
		ans=0;
		for(i=0; i<n; i++) {
			for(j=0; j<m; j++) {
				if(mp[i][j]=='@') {
					ans++;
					dfs(i,j);
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值