Problem c 统计元音的次数(第六讲)

题目描述
统计每个元音字母在字符串中出现的次数。

输入
输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串。

输出
a:num1
e:num2
i:num3
o:num4
u:num5
样例输入
2
aeiou
my name is ignatius
样例输出
a:1
e:1
i:1
o:1
u:1

a:2
e:1
i:3
o:0
u:1

 

#include <stdio.h>
#include <stdlib.h>

#define BUFFERSIZE 1024
char buffer[BUFFERSIZE];
char vowel_char_array[5]={'a','e','i','o','u'};
int vowel_count_array[5]={0,0,0,0,0};

int count_vowel_in_string(char *buff,int len,char vowel_char){
    int i=0;
    int count=0;
    for(i=0;i<len;i++){
        if(vowel_char==buff[i]){
            count=count+1;
        }
    }
    return count;
}

int main(){
    int i=0,j=0;
    char c;
    int count=0,len=0;
    scanf("%d",&count);
    getchar();  //work with scanf,just omit the special character
    for(i=0;i<count;i++){
        len=0;
        while((c=getchar())!='\n'){
            buffer[len]=c;
            len=len+1;
        }
        //gets(buffer);
        //printf("%s",buffer);
        for(j=0;j<5;j++){
            vowel_count_array[j]=count_vowel_in_string(buffer,len,vowel_char_array[j]);
        }
        /* display the vowel char count */
        for(j=0;j<5;j++){
            printf("%c:%d\n",vowel_char_array[j],vowel_count_array[j]);
        }
        printf("\n");
    }

}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值