kuangbin 基础DP1

A. Max Sum Plus Plus

Max Sum Plus Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12589 Accepted Submission(s): 4146

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. _

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output
6
8
Hint
Huge input, scanf and dynamic programming is recommended.

Author
JGShining(极光炫影)

题意:对应上面第二个案例,先输入一个数代表组数,然后输入多个数字,然后把这些数不能更改顺序的分成开头输入的数(可以有数不纳入任何一组内)得到最大值。比如第二列分为 6 -1 4 ------------------ 3 -2 3 两组之和为8
思路:这是一道dp题目,dp[i][j]记录着到第j个数为止把前面的数分为i组,并且第j个数要取得,所得到的最大值。
那么状态转移就是dp[i][j]=max(dp[i][j-1]+a[j],dp[i-1][i-1…j-1]+a[j])(其中后面指的是如果第j个数要自己独立成一组,那么就枚举组数为i-1的各种情况)
注意的是,为了防止空间溢出,就用2个滚动数组,pre[]记录着i-1的情况其中,pre[j]等价于dp[i-1]k的最大值

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
typedef long long ll;
ll dp[1001000];
ll pre[1001000];
int a[1001000];
using namespace std;


int main()
{
    int n,m;
    while(cin>>m>>n)
    {
        for(int i=1;i<=n;i++)
             scanf("%d",&a[i]);
        ll mx=-999999999;
        memset(dp,0,sizeof(dp));
        
        memset(pre,0,sizeof(pre));
        for(int i=1;i<=m;i++)
        {
            mx=-999999999;
            for(int j=i;j<=n;j++)
            {
                dp[j]=max(dp[j-1],pre[j-1])+a[j];
                pre[j-1]=mx;
                mx=max(dp[j],mx);
            }
        }
        printf("%lld\n",mx);
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值