poj 2891 中国剩余定理 模板

Strange Way to Express Integers

Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 20227 Accepted: 6823

Description

 

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

 

Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

 

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

 

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.


题意:

    给n对数(ai,bi) 表示一个数在对ai取余之后余数为bi,ai之间可能不互质,问你这个数是什么。

 

做法:

    中国剩余定理。。我表示不会。。难受 就留个板子。。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const int maxn=100005;
ll a[maxn],b[maxn],n;
ll exgcd(ll a,ll b,ll &x,ll &y){
    if(b==0){
        x=1,y=0;
        return a;
    }
    else {
        ll d=exgcd(b,a%b,y,x);
        y-=x*(a/b);
        return d;
    }
}
ll Sunzi(){
    ll lcm=1;
    ll ans=0;
    for(int i=1;i<=n;i++){
        ll x,y;
        ll d=exgcd(lcm,a[i],x,y);
        if((b[i]-ans)%d!=0) return -1;
        else {
            ll t=a[i]/d;
            x=(x*(b[i]-ans)/d%t+t)%t;
            ans=x*lcm+ans;
            lcm=lcm/d*a[i];
        }
    }
    return ans;
}

int main(){

    while(~scanf("%lld",&n)){
        for(int i=1;i<=n;i++)
            scanf("%lld%lld",&a[i],&b[i]);
        printf("%lld\n",Sunzi());
    }
    return 0;
}

求互质的数的模板:

  

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
ll n,a[15],b[15];
void exgcd(ll a,ll b,ll &x,ll &y){
    if (b==0){
        x=1;
        y=0;
        return ;
    }
    exgcd(b,a%b,y,x);
    y=(y-a/b*x);
}
int main(){
    ll n;
    scanf("%lld",&n);
    for(int i=1;i<=n;i++)
        scanf("%lld",&b[i]);
    for(int i=1;i<=n;i++)
        scanf("%lld",&a[i]);

    ll lcm=1,x,y;
    for(int i=1;i<=n;i++)
        lcm*=a[i];
    ll ans=0;
    for(int i=1;i<=n;i++){
        ll now=lcm/a[i];
        exgcd(now,a[i],x,y);
        x=((x%a[i])+a[i])%a[i];
        ans=(ans+x*b[i]*now)%lcm;
    }
    printf("%lld\n",ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值