树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7

2 3 1 5 7 6 4

1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

#include <stdio.h>
#include <stdlib.h>
#include <mm_malloc.h>
typedef struct Bnode
{
    int data;
    struct Bnode *Lson,*Rson;
}Bnode,*Bptr;
void level(Bptr p, Bptr c[],int n)
{
    int f=0,l=0,i;
    c[l]=p;
    l++;
    while(l<n)
    {
        if (c[f]->Lson!=NULL) {
            c[l]=c[f]->Lson;
            l++;
        }
        if (c[f]->Rson!=NULL) {
            c[l]=c[f]->Rson;
            l++;
        }
        f++;
    }
    for(i=0;i<n-1;i++)
    {
        printf("%d ",c[i]->data);
    }
    printf("%d",c[n-1]->data);
}
Bptr Creat(int a[],int b[],int i,int j,int s,int t)
{
    int k;
    Bptr p;
    if (i>j) {
        return NULL;
    }
    p=malloc(sizeof(Bnode));
    p->data=a[j];
    k=s;
    while ((k<=t)&&(b[k]!=a[j])) {k++;}
        if (b[k]!=a[j]) {
            printf("ERROR/n");
            exit(1);
        }
        p->Lson=Creat(a, b, i, i+k-s-1, s, k-1);
        p->Rson=Creat(a, b, i+k-s, j-1, k+1, t);
    return p;
}
void fun(int N)
{
    int a[N],b[N];
    Bptr c[N];
    int i;
    Bptr root;
    for(i=0;i<N;i++)
    {
        scanf("%d",&a[i]);
    }
    for(i=0;i<N;i++)
    {
        scanf("%d",&b[i]);
    }
    root=Creat(a,b,0,N-1,0,N-1);
    level(root,c,N);
}
int main()
{
    int N;
    scanf("%d",&N);
    fun(N);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值