Ubiquitous Religions

题目:
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
Huge input, scanf is recommended.

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 50005
int p[MAX];
int rank[MAX];
int sum2 = 1,sum;
int find_father(int x)
{
	int r = x,temp;
	while(r != p[r]) r = p[r];
	while(x != p[x])
	{
		temp = p[x];
		p[x] = r;
		x = temp;
	}
	return x;
}
void combine(int a,int b)
{
	int c = find_father(a);
	int d = find_father(b);
	if(c == d) return;
	if(rank[c] > rank[d]) p[d] = c;
	else{
		p[c] = d;
		if(rank[c] == rank[d]) rank[c]++;
	}
}
void init(int n)
{
	for(int i = 1;i <= n;i++) 
	{
		p[i] = i;
		rank[i] = 0;
	}
}
int main()
{
	int n,m,a,b;
	while(~scanf("%d%d",&n,&m)){
		if(n == 0){
			if(m == 0) break;
			else {
				cout << "Case " << sum2 << ": " << sum << endl;
				sum2++;
				continue;
			}
		}
		init(n);
		sum = 0;
		for(int i = 0;i < m;i++){
			cin >> a >> b;
			combine(a,b);
		}
		for(int i = 1;i <= n;i++){
			if(p[i] == i) sum++;
		}
		cout << "Case " << sum2 << ": " << sum << endl;
		sum2++;
	}
	return 0;
}

这是一道简单的并查集题目,这里将同样宗教信仰的学生归为一类,为了降低寻找父结点的时间,可以采用路径压缩,或者在合并时高度低的归为高度高的那类,依次来减少总体高度。

计算宗教总数时,遍历所有学生,要是这个点父结点等于其本身就总数累加。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值