POJ - 3273 Monthly Expense

题目:
Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
Line 1: Two space-separated integers: N and M
Lines 2… N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
代码如下:

#include<iostream>
#include<cstdio> 
using namespace std;
#define MAX 1000005
int a[MAX];
int n,m,mid,r = 0,l = -1;
int check(int k)
{
	int res = 0,num = 0;
	for(int i = 0;i < n;i++){
		if(res + a[i] <= k) res += a[i];//还没到给定值,继续归为同一组 
		else res = a[i],num++;//超出给定值另外分一组 
	}
	return num;
}
int main()
{
	cin >> n >> m;
	for(int i = 0;i < n;i++){
		cin >> a[i];
		r += a[i];//上边界选取所有价值总和 
		l = max(l,a[i]); 
	}
	while(l < r){
		mid = (l + r) / 2;
		int v = check(mid);//v值代表当每组之和不超过mid时所能分到的组数 
		if(v < m) r = mid - 1;//组数小于给定组数代表mid值太大,选取前一半 
		else l = mid + 1;//数组大于给定组数,选后一半 
	}
	cout << r << endl;
	return 0;
}

题意:
给定n个数,要求划分m组,而且要连续划分。求所有分组中最高花费中的最小值。
思路:
这道题采用二分的思路,下界就是n个花费中的最大值,这样可以保证每个数都可以分进组中。上界就是所有花费之和,这代表最少分为1组,也就是所有花费都分到一组中。然后进行二分(也就是把mid当作每组可以分的上限值),每次计算可以分到多少组,如果分的组少于给定的m组,说明这个数太大了,要往小的分,所以再考察看一半。如果分的组大于给定的m组,说明这个数太小,可以往大的分,所以考察后一半。最后当r < l跳出循环。(代码有注释)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值