woj1264

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

输入格式

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.
You may assume that the resulting date won

输出格式

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

样例输入

1730
1740
1750
1751
-1

样例输出

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday

 

#include<stdio.h>
#include<stdlib.h>
int MM1[12] = { 31,28,31,30,31,30,31,31,30,31,30,31 };
int MM2[12] = { 31,29,31,30,31,30,31,31,30,31,30,31 };
int n;
int getY()
{
	int year=2000;
	while (n >= 0) 
	{
		if ((year % 4 == 0 && year % 100 != 0) || (year % 400 == 0))
		{
			if (n - 366 >= 0)
			{
				year++;
				n = n - 366;
			}
			else
				return year;
		}
		else
		{
			if (n - 365 >= 0)
			{
				year++;
				n = n - 365;
			}
			else
				return year;
		}
	}
}
int getM(int year)
{
	int month = 0;
	while (n >= 0)
	{
		if ((year % 4 == 0 && year % 100 != 0) || (year % 400 == 0))
		{
			if (n - MM2[month] >= 0)
			{
				n = n - MM2[month];
				month++;
				
			}
			else
			{
				return month + 1;
			}
		}
		else
		{
			if (n - MM1[month] >= 0)
			{
				n = n - MM1[month];
				month++;
				
			}
			else
			{
				return month + 1;
			}
		}
	}
}
int main()
{
	while (scanf("%d", &n) && n != -1)
	{
		int Y, M, D, DoW;
		DoW = (n + 6) % 7;
		Y = getY();
		M = getM(Y);
		D = n+1;
		switch (DoW)
		{
		case 0:printf("%d-%02d-%02d Sunday\n", Y, M, D); break;
		case 1:printf("%d-%02d-%02d Monday\n", Y, M, D); break;
		case 2:printf("%d-%02d-%02d Tuesday\n", Y, M, D); break;
		case 3:printf("%d-%02d-%02d Wednesday\n", Y, M, D); break;
		case 4:printf("%d-%02d-%02d Thursday\n", Y, M, D); break;
		case 5:printf("%d-%02d-%02d Friday\n", Y, M, D); break;
		case 6:printf("%d-%02d-%02d Saturday\n", Y, M, D); break;
		default:
			break;
		}
		
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值