PAT-1028(乙级)

1028 人口普查 (20 分)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数 N,取值在(0,10​5​​];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

 解题思路:

本题实际是比较两个给定日期的的大小。因此可以采用year * 10000 + month * 100 + day的方法。

#include<iostream>
#include<cmath>
using namespace std;

struct people{
	string name;
	string born_time;
	long long day;
};

int toInteger(string str){//string 转整型
	int len = str.length();
	int num = 0;
	while(len > 0){
		num += (str[str.length() - len] - '0') * pow(10, len - 1);	
		len--;
	}
	return num;
}
long long getTime(string born_time){//获取字符串年月日,且按格式返回
	int year = toInteger(born_time.substr(0, 4));
	int month = toInteger(born_time.substr(5, 2));
	int day = toInteger(born_time.substr(8, 2));
	return year * 10000 + month * 100 + day;
}


int main(){
	int n, count = 0, max_index = 0, min_index = 0;
	cin >> n;
	people pep[n];
	long long min = 20140906, max = 18140906;
	for(int i = 0; i < n; i++){//输入且比较
		cin >> pep[i].name >> pep[i].born_time;
		pep[i].day = getTime(pep[i].born_time);
		if(pep[i].day <= 20140906 && pep[i].day >= 18140906){
			count++;
			if(pep[i].day > max){
				max = pep[i].day;
				min_index = i;
			}
			if(pep[i].day < min){
				min = pep[i].day;
				max_index = i;
			}
		}
	}
	if(count)
		cout << count << " " << pep[max_index].name << " " << pep[min_index].name;
	else 
		cout << 0;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值