题目49:Least Common Multiple

题目描述

题目描述:
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set . For example, the LCM of 5,7 and 15 is 105.
输入:
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers.All integers will be positive and lie within the range of a 32-bit integer.
输出:
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer. ( 输出:对于每个问题实例,输出包含相应LCM的一行。 所有结果将在32位整数的范围内。)
样例输入:
2
3 5 7 15
6 4 10296 936 1287 792 1
样例输出:
105
10296

解题思路

#include<iostream>
#include<algorithm>
using namespace std;
bool cmp1(long long x,long long y)
{
	return x>y;
}
int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		int m;
		cin>>m;
		long long a[1000];
		for(int j=0;j<m;j++)
		{
			cin>>a[j];
		}
		sort(a,a+m,cmp1);//取出最大值 
		bool flag;
		long long k; 
		for(k=a[0];;k++)
		{
			flag=true;
			for(int l=0;l<m;l++)
			{
				if(k%a[l]!=0)
				{
					flag=false;
					break;
				}
			}
			if(flag==true)
			{
				break;
			} 
		} 
		cout<<k<<endl;
		
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值