HDU1312 Red and Black

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 

Sample Output

45
59
6
13

思路:和普通的迷宫是一样的,相当于‘#’是墙,求出这个人能够到达的瓷砖的总个数。
用BFS,

代码:

#include<bits/stdc++.h>
using namespace std;
int dx[]={0,0,-1,1};
int dy[]={1,-1,0,0};
int n,m;
char a[50][50];
bool f[50][50];
struct s{
   int c,d;
};
int bfs(int x,int y){
	int summ=1;
	queue<s>q;
	s t,t1;
	t.c=x,t.d=y;
	q.push(t);
	f[x][y]=true;
	while(!q.empty()){
		t=q.front();
		q.pop();
		for(int i=0;i<4;i++){
			t1.c=t.c+dx[i],t1.d=t.d+dy[i];
		  if(t1.c>=0&&t1.c<m&&t1.d>=0&&t1.d<n&&!f[t1.c][t1.d]&&a[t1.c][t1.d]!='#'){
		  	q.push(t1);
		  	f[t1.c][t1.d]=true;
		  	summ++;
		  }
		}
	}
	return summ;
}
int main()
{
   while(cin>>n>>m&&n&&m){
   	int c,d;
   	for(int i=0;i<m;i++){
   		for(int j=0;j<n;j++){
   			f[i][j]=false;
   			cin>>a[i][j];
   			if(a[i][j]=='@')  c=i,d=j; 
		   }
	   }
	  cout<<bfs(c,d)<<endl;
   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值