Pascal's Travels

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress. 


Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 


Figure 1


Figure 2
InputThe input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them. 
OutputThe output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 
Sample Input
4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1
Sample Output
3
0
7


        
  
Brute force methods examining every path will likely exceed the allotted time limit. 
64-bit integer values are available as "__int64" values using the Visual C/C++ or "long long" values 

using GNU C/C++ or "int64" values using Free Pascal compilers.

题意:给出n,接下来n行n列,每个数表示能走几步,方向只能向下或向右,问从左上角到右下角一共有多少种方法(对了,方法太多,用longlong或者_int64)就酱~

思路:本人鶸一个,什么也不会,看到大神代码理解的思路,嘤嘤嘤~写博客是为了抗遗忘,dp的思路真的很。。。大佬了

接下来是代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[40][40];
int a[40][40];
long long dp[40][40];
int main()
{
    int t;
    while(~scanf("%d",&t)&&(t!=-1))//你们懂的
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<t;i++)
            scanf("%s",s[i]);
        for(int i=0;i<t;i++)
            for(int j=0;j<t;j++)
        {
            a[i][j]=s[i][j]-'0';
        }
       dp[0][0]=1;//第一步欸
       for(int i=0;i<t;i++)
            for(int j=0;j<t;j++)
       {
           if(a[i][j]==0||dp[i][j]==0)continue;
           if(a[i][j]+i<t)//未越界
            dp[i+a[i][j]][j]+=dp[i][j];
            //到此处的值等于加上上一步的值
            //而到此步有可能有多条路
           if(a[i][j]+j<t)
            dp[i][j+a[i][j]]+=dp[i][j];
       }
       printf("%lld\n",dp[t-1][t-1]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值