File Transfer

05-树8 File Transfer (25 分)

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2N104​​), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2

where I stands for inputting a connection between c1 and c2; or

C c1 c2

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.

 

 

 

#include <iostream>
#include <vector>
using namespace std;
//考查并查集 
#define Max_Node 10001
typedef struct{
    int parent;
}Node;

int Find_Set(vector<Node> &set, int value){
//寻找当前value所在的并查集根节点
    while(set[value].parent > 0){//这里判断的依据为根节点为负值 
        value = set[value].parent;//一直不停的向上找根节点 
    }
    return value;//返回根节点    
}

void Union_Set(vector<Node> &set, int value1, int value2){
    //合并两个节点的并查集
    int root1 = Find_Set(set, value1);//找到value1节点所在集合的根节点 
    int root2 = Find_Set(set, value2);//找到value2节点所在集合的根节点 
    if(set[root1].parent < set[root2].parent){//注意根节点的绝对值代表本集合内节点的个数 
        //以root1为根的并查集的节点个数更多
        //将并查集节点个数少的合并到节点个数多的并查集
        set[root2].parent = root1;
        set[root1].parent--;    //root1的节点个数加1 
    }else{
        set[root1].parent = root2;//同理 
        set[root2].parent--;
    }
}

bool Check_Set(vector<Node> &set, int value1, int value2){
        //查询两个节点是否属于同一个并查集
        int root1 = Find_Set(set, value1);
        int root2 = Find_Set(set, value2);
        if(root1 == root2){
            return true;
        }else{
            return false;    
        }
}

int Count_Set(vector<Node> &set){
    //查询当前并查集的个数
    int count = 0;
    for(int i = 1; i < set.size(); ++i){
        if(set[i].parent < 0){
            count++;
        }
    } 
    return count++;//这里有些不明白 
}
int main(){
    int N;
    cin >> N;
    vector<Node> Set(N + 1);
    char c;
    int value1, value2;
    for(int i = 0; i < Set.size(); i++){
        Set[i].parent = -1;//各成一派 
    }
    while(true){
        cin >> c;
        if(c == 'C'){
            cin >> value1 >> value2;
            if(!Check_Set(Set, value1, value2)){
                cout << "no" << endl;
            }else{
                cout << "yes" << endl;
            }
        }else if(c == 'I'){
            cin >> value1 >> value2;
            if(!Check_Set(Set, value1, value2)){
                Union_Set(Set, value1, value2);
            }
        }else{
            if(Count_Set(Set) > 1){
                cout << "There are " << Count_Set(Set) << " components.";
            }
            else{
                cout << "The network is connected.";  
            }
            
            break;
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值