二叉树遍历

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18570    Accepted Submission(s): 7672


 

Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

 

 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

 

Sample Input
 
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

 

Sample Output
 
7 4 2 8 9 5 6 3 1
 

 

Source
 
#include <iostream>
#include <stdio.h>
#include <vector>

using namespace std;

int pre[1010], mid[1010];

//只是dfs,不用采用struct结构存储node

void dfs(int &pre_i, int m_left, int m_right){		//以pre为基准,遍历,要保证pre_i一直向前推进,pre中每个元素都能在mid中找到对应,只访问一次
	int flag=-1, pi=pre_i;							//pre_i向前推进,回溯之后pre_i也不会倒退,需要另一个变量标记pre中第一个元素,因为输出有特判
	for(int i=m_left; i<=m_right; ++i){
		if(pre[pre_i]==mid[i]){
			flag=i;
			++pre_i;
			break;
		}
	}
	if(flag==-1)
		return;
	if(flag>m_left)
		dfs(pre_i, m_left, flag-1);
	if(flag<m_right)
		dfs(pre_i, flag+1, m_right);
	cout << mid[flag];
	if(pi!=1)
		cout << ' ';
}

int main(){
	int n=0;
	while(cin >> n){
		for(int i=1; i<=n; ++i){
			cin >> pre[i];
		}
		for(int i=1; i<=n; ++i){
			cin >> mid[i];
		}		
		int x=1;
		dfs(x,1,n);
		cout << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值