PAT甲级1116 Come on! Let's C (20 分)

1116 Come on! Let's C (20 )

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤104), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6

1111

6666

8888

1234

5555

0001

6

8888

0001

1111

2222

8888

2222

Sample Output:

8888: Minion

0001: Chocolate

1111: Mystery Award

2222: Are you kidding?

8888: Checked

2222: Are you kidding?

      题目大意:

     给出n个排名信息,以及n个查询。如果是冠军则输出Mystery Award如果排名是素数则输出Minion, 如果是其他的则输出Chocolate。同时如果并没有这号人,则输出Are you kidding? ,如果询问过了,则输出Checked

思路:

         由于要根据排名进行相应的输出所有struct node 中肯定要有r,保存排名,同时存储一个flag 用于识别是否查询过,接着就是写好isprime算法即可。

参考代码:

 

 

#include<cstdio>
struct node{
	int r;
	bool flag;
}list[100000];
int n;
bool isprime(int v){
	if(v <= 1) return false;
	for(int i = 2; i * i <= v; ++i )
		if(v % i == 0)	return false;
	return true;
}
int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		int id;
		scanf("%d", &id);
		list[id].r = i + 1;
	}
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		int id;
		scanf("%d", &id);
		printf("%04d: ", id);
		if(list[id].flag && list[id].r != 0) printf("Checked\n");
		else{
			if(list[id].r  == 0)	printf("Are you kidding?\n");
			else if(list[id].r == 1) printf("Mystery Award\n");
			else if(isprime(list[id].r)) printf("Minion\n");
			else printf("Chocolate\n");
		}
		list[id].flag = true;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值