PAT甲级1117 Eddington Number (25 分)

1117 Eddington Number (25 )

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer Esuch that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

      题目大意:

给出n天的骑行距离求爱丁顿数,即求有 e 天 他都骑行超过了e公里,求最大的e。

思路:

         将数据从大到小排列,如果这么多天内最多骑行距离都不超过1公里,那么爱丁顿数就等于0,可推论至i天如果这一天是最大的满足条件的天数,可以容易证明I + 1天是不满足的,(因为从大到小排序了)。

参考代码:

 

 

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int n, e;
vector<int>list;
int main(){
	scanf("%d", &n);
	list.resize(n);
	for(int i = 0; i < n; ++i)	scanf("%d", &list[i]);
	sort(list.begin(), list.end(), greater<int>());
	while(e < n && list[e] > e + 1) e++;
	printf("%d", e);
	return 0;	
}

代码参考:https://blog.csdn.net/liuchuo/article/details/52505043

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值