PAT甲级1118 Birds in Forest (25 分)

1118 Birds in Forest (25 )

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (104) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B1 B2 ... BK

where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

      题目大意:

给出n张照片,随后n行即是每张照片上的鸟的数量以及代号,输出森林的数的总数,以及鸟的总数。注意鸟的编号是不唯一的,且每一张照片上的鸟是属于那棵树的,随后给出q次查询,给出一对鸟的编号,问是否在同一棵树上。

思路:

         用并查集解决,没一次读取一张照片,就让相应的鸟的编号Union,对于鸟的总数的统计,用一个集合来表示,每次都录入exist中,exist的size就是鸟的总数。录入所有信息后,如果找到指向自己的就是一颗树,统计个数。

参考代码:

 

 

#include<cstdio>
#include<vector>
#include<set>
using namespace std;
set<int> exist;
int father[100000];
int findfather(int x){
	if(x == father[x]) return x;
	int f = findfather(father[x]);
	father[x] = f;
	return f;
}
void Union(int a, int b){
	int fa = findfather(a), fb = findfather(b);
	if(fa != fb) father[fa] = fb;
}
int n, k, nt, q;
int main(){
	scanf("%d", &n);
	for(int i = 0; i < 100000; ++i)	father[i] = i;
	for(int i = 0; i < n; ++i){
		scanf("%d", &k);
		for(int j = 0; j < k; ++j){
			int a, last;
			scanf("%d", &a);
			exist.insert(a);
			if(j != 0)	Union(a, last);
			last = a;
		}
	}
	for(auto it = exist.begin(); it != exist.end(); ++it)
		if(father[*it] == *it) nt++;
	scanf("%d", &q);
	printf("%d %d\n", nt, exist.size());
	for(int i = 0; i < q; ++i){
		int a, b;
		scanf("%d %d", &a, &b);
		if(findfather(a) == findfather(b)) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值