PAT甲级1147 Heaps (30 分)

1147 Heaps (30 )

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

   题目大意:

        查询k次,以及有n个结点的堆,随后k行为该堆的层序序列。判定是否为堆,如果是则是大顶堆还是小顶堆。随后给出后序序列。
 

 

思路:

  1. 由于给的就是层序,相当于给了一棵静态二叉树了。
  2. 先判定是否为堆,先假设是否为大顶或小顶堆,int flag = (1或-1),用list[0] 与list[1]的大小先进行预估。
  3. 如果是堆了,还要判断其余地方是否也满足堆的定义:由CBT性质知道,最后一个分支结点的下标为 (int) n / 2,那么就从0 ~ n / 2,判断他们的孩子与父亲的大小关系。注意分支结点至少是存在左孩子的。
  4. 编写后序遍历算法。

参考代码:

 

 

 

#include<vector>
#include<cstdio>
using namespace std;
int k, n;
vector<int> list;
void post(int v){
	if(v >= n) return;
	post(2 * v + 1);
	post(2 * v + 2);
	printf("%d%c", list[v], v != 0? ' ': '\n');
}
int main(){
	scanf("%d%d", &k, &n);
	list.resize(n);
	for(int i = 0; i < k; ++i){
		list.clear();
		for(int j = 0; j < n; ++j)	scanf("%d", &list[j]);
		int flag = list[0] >= list[1]? 1 : -1;
		for(int j = 0; j <= (n - 1) / 2; ++j){
			int l = 2 * j + 1, r = 2 * j + 2;
			if(flag == 1){
				if(list[l] > list[j] ||(r < n && list[r] > list[j])) flag = 0;
			}
			else if(list[l] < list[j] || (r < n && list[r] < list[j])) flag = 0;
		}
		if(!flag)	printf("Not Heap\n");
		else if(flag == -1)	printf("Min Heap\n");
		else  printf("Max Heap\n");
		post(0);
	}
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/79810648

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值