PAT甲级1150 Travelling Salesman Problem (25 分)

1150 Travelling Salesman Problem (25 )

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C1 C2 ... Cn

where n is the number of cities in the list, and Ci's are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

   题目大意:

        给定一个n个结点和m条边的图,随后给p次查询,每次给出长度为k的路径序列,请问是否为一个环或是否为简单环。
 

 

思路:

  1. 用临接矩阵存储图,如果list[k – 1] != list[0] ) 表示非环。此时还只能假设是存在环的,但是不一定每个结点都访问了:用vis表示序列中每个结点的访问次数,如果每个结点都访问到了那么至少是环了,否则还是非环。还要注意的是当发现了路径不是通路时,让total = -1, 也即非环。下一步如果vis[list[0] ] != 2 或者其他结点的vis大于1,则是非简单环。

参考代码:

 

 

 

#include<vector>
#include<cstdio>
using namespace std;
int n, m, p, k;
int main(){
	scanf("%d%d", &n, &m);
	vector<vector<int> > e(n + 1, vector<int>(n + 1, 0));
	for(int i = 0; i < m; ++i){
		int a, b;
		scanf("%d%d", &a, &b);
		scanf("%d", &e[a][b]);
		e[b][a] = e[a][b];
	}
	scanf("%d", &p);
	int idx = -1, minv = 0x7fffffff;
	for(int i = 1; i <= p; ++i){
		scanf("%d", &k);
		vector<int> list(k), vis(n + 1);
		printf("Path %d: ", i);
		int total = 0, last;
		for(int j = 0; j < k; ++j){
			scanf("%d", &list[j]);
			vis[list[j]]++;
			if(j != 0){
				if(!e[last][list[j]]) total = -1;
				if(total != -1)	total += e[last][list[j]];
			}
			last = list[j];
		}
		if(total == -1) printf("NA ");
		else	printf("%d ", total);
		if(list[0] != list[k - 1] || total == -1)	printf("(Not a TS cycle)\n");
		else{
			bool flag = true, iss = true;
			for(int j = 1; j <= n; ++j)
				if(!vis[j])	flag = false;
				else if((j != list[0] && vis[j] > 1) || (j == list[0] && vis[j] != 2) ) iss = false;
			if(!flag){
				printf("(Not a TS cycle)\n");
				continue;
			}
			if(iss) printf("(TS simple cycle)\n");
			else printf("(TS cycle)\n");
			if(minv > total) minv = total, idx = i;
		}
	}
	printf("Shortest Dist(%d) = %d", idx, minv);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值