PAT甲级1154 Vertex Coloring (25 分)

1154 Vertex Coloring (25 )

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

   题目大意:

         给出n个结点m条边的图,随后有k次着色,要求一条边上的两个点要有不同的颜色,询问最多能有多少种颜色。

思路:

      关于边的算法,用临接矩阵存储,枚举每一条边,如果同一边的两点是相同颜色的,就令flag = false,输出No,所有边都不同的时候就输出color,color在录入颜色的时候就记录了不同的颜色。

 

参考代码:

 

 

 

#include<vector>
#include<cstdio>
#include<set>
using namespace std;
struct node{
	int v1, v2;
};
vector<node> list; 
int main(){
	int n, m, k;
	scanf("%d%d", &n, &m);
	list.resize(n);
	for(int i = 0; i < m; ++i) scanf("%d%d", &list[i].v1, &list[i].v2);
	scanf("%d", &k);
	for(int i = 0; i < k; ++i){
		bool flag = true;
		vector<int> w(n);
		set<int> color;
		for(int j = 0; j < n; ++j) scanf("%d", &w[j]), color.insert(w[j]);
		for(int j = 0; j < m; ++j)
			if(w[list[j].v1] == w[list[j].v2]){
				flag = false;
				break;
			}
		if(!flag) printf("No\n");
		else printf("%d-coloring\n", color.size());
	}
	return 0;
} 

代码参考:https://blog.csdn.net/liuchuo/article/details/84973030

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值