PAT甲级 A1024 Palindromic Number (25 分)

题目:

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题目大意: 

  给定一个数列,若非回文串则令其与其相反的数列相加,直至成为回文串或是达到给定的相加次数为止。

思路: 

  1、数据结构用结构体bign{int len,d[1000]}。因为是最多是10位的数操作100次,故应为110长度以上的数组(证明:10位数相加,最多进一位形成11位数,即一次操作添加一位,100次操作添加一百位,110位为最小值)

  2、需要判定回文串的函数

  3、需要使字符串与bign间转换的函数

  4、需要相加的函数,此时有两个选择,一是不构造新的bign变量,直接使a.d[i]+a.d[a.len-1-i]+carry,即原来的最高位与最低位相加,且依次首尾相加。第二种选择是用reverse函数将a相反后相加。

  5、一旦到了最大操作次数或者变成了回文串则输出。

 

  

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct bign{
	int len,d[1000];
	bign(){
		len=0;
		memset(d,0,sizeof(d));
	}
}; 

bign change(char a[]){
	bign ans;
	ans.len=strlen(a);
	for(int i=0;i<ans.len;++i){
		ans.d[i]=a[ans.len-1-i]-'0';
	}
	return ans;
}

bool isPalindromic(bign a){
	for(int i=0;i<a.len/2;++i){
		if(a.d[i]!=a.d[a.len-1-i]) return false;
	}
	return true;
}

bign add(bign a, bign b){
	bign ans;
	int carry=0;
	for(int i=0;i<a.len;++i){
		int temp=a.d[i]+b.d[i]+carry;
		ans.d[ans.len++]=temp%10;
		carry=temp/10;
	}
	if(carry)	ans.d[ans.len++]=carry;
	return ans;
}

void showArray(bign a){
	for(int i=a.len-1;i>=0;--i){
		printf("%d",a.d[i]);
	}
	printf("\n");
}

int main (){
	char s[11];
	int k,step=0;
	scanf("%s%d",s,&k);
	bign a=change(s);
	while(step<k&&!isPalindromic(a)){
		bign b=a;
		reverse(b.d,b.d+b.len);
		a=add(a,b);
		step++;
	}
	showArray(a);
	printf("%d\n",step);
	return 0;
}

注:有部分代码参考《算法笔记》

如有新的想法会及时更新

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值