PAT 甲级A1094 The Largest Generation (25 分)

题目:

1094 The Largest Generation (25 分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

题意:

  统计族谱中每一代人的个数,并且输出最大的那一代人的人数和代数。(夫妻两共用同一结点)

思路:

  最直观的便是用BFS,然后只要弄清楚在BFS中怎么分清楚层次,在当层进行相关的人数统计。可知,每一层的人数都由其父结点的孩子结点个数决定的,由此可得每一次都累加同一层的结点的孩子结点个数作为下一层的控制。由此可知,当需要在BFS算法中要进行打断时可以用本文的算法。

  当然,最简洁的写法是用DFS然后利用hashtable【level】进行相关层数的统计。只要进入了该层,则该层的hashtable 加一。此写法在算法二中。

#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 110;
vector <int> tree[maxn];
int maxnum = 0, md;
void LayerOrder(int root, int depth, int cntrl){
	queue< int > q;
	q.push(root);
	int num, newcntrl;
	while(!q.empty()){
		num = 0, newcntrl = 0;
		for(int i = 0; i < cntrl; ++i){
			int top = q.front();
			q.pop();
			num ++;
			newcntrl += tree[top].size();
			for(int i = 0; i < tree[top].size(); ++i){
				q.push(tree[top][i]);
			}
		}
		cntrl = newcntrl;
		if( num > maxnum){
				maxnum = num;
				md = depth;
		}
		depth++;
	}
}

int main(){
	int n,m;
	scanf("%d%d",&n, &m);
	for(int i = 1; i <= m; ++i){
		int temp, k;
		scanf("%d%d", &temp, &k);
		tree[temp].resize(k);
		for(int j = 0; j < k; ++j){
			scanf("%d", &tree[temp][j]);
		}
	}
	LayerOrder(1,1,1);
	printf("%d %d\n",maxnum, md);
	return 0;
}

 

 算法二:

#include<cstdio>
#include<vector>
using namespace std;
const int maxn = 110;
vector <int> tree[maxn];
int hashtable[maxn]={0};

void DFS(int root, int level){
	hashtable[level]++;
	for(int i = 0; i < tree[root].size(); ++i){
		DFS(tree[root][i], level + 1);
	}
}

int main(){
	int n, m;
	scanf("%d%d", &n, &m);
	for(int i = 0; i< m; ++i){
		int temp, k;
		scanf("%d%d", &temp, &k);
		tree[temp].resize(k);
		for(int j = 0; j < k; ++j){
			scanf("%d", &tree[temp][j]);
		}
	}
	DFS(1,1);
	int maxnum = 0, maxlevel;
	for(int i = 1; i < maxn; ++i){
		if(maxnum < hashtable[i]){
			maxlevel = i;
			maxnum = hashtable[i];
		}
	}
	printf("%d %d\n", maxnum, maxlevel);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值