PAT 甲级1003 Emergency (25 分)

1003 Emergency 25 )

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (500) - the number of cities (and the cities are numbered from 0 to N1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

 

题目大意:

   有n个城市与m条路径,且每当从其他城市打来的援助电话时,你需要从你所在的城市出发,尽快的到达救援的城市;同时在途经其他城市时,将把该城市的救援队员叫上。要求最短且带上的救援队员最多的那条路径。要求输出最短路径条数以及所能叫上的最大救援队员的数量。

思路:

  利用Dijkstra算法,设置num[maxn] 变量存储到某城市最短路径的条数, w[maxn] 存储到某城市能叫上的最多的救援队员的数量,dis[maxn]存储从出发的城市到其他城市的最短路径的长度且初始化为INF。

 

参考代码:

#include<cstdio>
#include<algorithm>
using namespace std;
int g[500][500];
int w[500], num[500], dis[500], weight[500];
bool vis[500];
int c1, c2, n, m;
const int inf = 0x3fffffff; 
void dijkstra(){
	fill (dis, dis + n, inf);
	dis[c1] = 0, num[c1] = 1, w[c1] = weight[c1];
	for(int i = 0; i < n; ++i){
		int min = inf, u = -1;
		for(int j = 0; j < n; ++j)
			if(!vis[j] && dis[j] < min)	min = dis[j], u = j;
		if(u == -1)	return ;
		vis[u] = true;
		for(int v = 0; v < n; ++v)
			if(g[u][v] && !vis[v]){
				if(g[u][v] + dis[u] < dis[v]){
					dis[v] = dis[u] + g[u][v];
					num[v] = num[u];
					w[v] = w[u] + weight[v];
				} else if (g[u][v] + dis[u] == dis[v]){
					num[v] += num[u];
					if(w[u] + weight[v] > w[v])	w[v] = w[u] + weight[v];
				}
			}
	}
}
int main (){
	int a, b;
	scanf("%d%d%d%d", &n, &m, &c1, &c2 );
	for(int i = 0; i < n; ++i)	scanf("%d", &weight[i]);
	for(int i = 0; i < m; ++i){
		scanf("%d%d", &a, &b);
		scanf("%d", &g[a][b]);
		g[b][a] = g[a][b];
	}
	dijkstra();
	printf("%d %d", num[c2], w[c2]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值