PAT 甲级1008 Elevator (20 分)

1008 Elevator 20 )

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

 

题目大意:

  给定k个数字,数字表示用户要到的楼层,由此模拟电梯运行:一开始电梯停在第0层, 如果电梯向上运行则每升高一层楼都将花费6 s,而向下运行每下降一层楼会花费4 s,且每次到了用户指定的层数,电梯都会停留5 s。最后电梯不用回到第0层。请输出总共花费的时间。

  注意如果当前电梯在第i层,且用户刚好就要去第i层,仍然需要停留5 s。

 

思路:

  因为有n 个请求将会停留n次,则总时间ans 初始化 n * 5。然后读入请求列表,判断当前楼层和下一个要去的楼层,如果要上升电梯则相应的 ans += 6 * (next - now)。否则 ans += 4 * (now – next)。

 

参考代码:

#include<cstdio>
int n, ans, now, next;
int main(){
	scanf("%d", &n);
	ans = n * 5; 
	for(int i = 0; i < n; ++i){
		scanf("%d", &next);
		if(next > now)	ans += 6 * (next - now);
		else	ans += 4 * (now - next);
		now = next;
	}
	printf("%d", ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值