PAT甲级1025 PAT Ranking (25 分)

1025 PAT Ranking (25 )

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大意:

         给定n个考场且每个考场有k个考生记录。记录包含了考生的id、得分。需要输出总表,总表按照得分排名,若得分相同id小的靠前,且需要输出总排名,来自的考场号,与其在相应考场的排名。

思路:

         用一个temp作为临时表,每次录入后进行local rank 的排序。在排序的时候可以录入总表中,录入所有考场后,总表再排序。

        

 

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct stu{
	long long id;//大于13位,用长整型 
	int scr, loc, locr, finr;//分别存储 成绩、考场号、考场排名、最终排名 
}; 
vector <stu> temp, list;//temp存储每个考场情况,list存储总体情况 
bool cmp(stu a, stu b){
	return a.scr != b.scr? a.scr > b.scr: a.id < b.id; //成绩高的排前面,成绩相同时 ,id小的排前面 
}
int main(){
	int n, k;
	cin >> n;
	for(int i = 1; i <= n; ++i){//一共录入n个考场,并且i也是考场编号 
		cin >> k;
		temp.resize(k);
		for(int j = 0; j < k; ++j){//录入id、成绩和考场号 
			cin >> temp[j].id >> temp[j].scr;
			temp[j].loc = i;
		}
		sort(temp.begin(), temp.end(), cmp); 
		int r = 1;//考场内排名,并且录入list中 
		for(int j = 0; j < k; ++j){
			if(j > 0 && temp[j].scr != temp[j - 1].scr) r = j + 1;
			temp[j].locr = r;
			list.push_back(temp[j]);
		}
	}
	sort(list.begin(),list.end(),cmp);
	cout << list.size()<<endl;
	int r = 1;//最终排名,且由于13位的id会存在先导0的情况,输出控制要注意 
	for(int i = 0; i < list.size(); ++i){
		if(i > 0 && list[i].scr != list[i-1].scr) r = i+1;
		list[i].finr = r;
		printf("%013lld %d %d %d\n", list[i].id, list[i].finr, list[i].loc, list[i].locr); 
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值