PAT甲级1026 Table Tennis (30 分)

1026 Table Tennis (30 )

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (≤10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (≤100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:

9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2

Sample Output:

08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2

题目大意:

         给定n个记录,记录代表着乒乓球俱乐部会员到场时间,以及他们训练的时间和是否为vip。同时给定k张桌子,其中有m张是vip桌子。

         按照如下规则安排:如果等待的队列里有vip且当前空出的桌子是vip桌子,则优先让vip会员用,如果当前的桌子不是vip桌子,则按照先到先得原则。且如果等待的队列里有vip一定优先让vip去vip桌子。

 

思路:

         因为要经常分配桌子,最好写一个分配算法,同时写找队列里的vip的算法。

        

参考代码:

#include<cstdio>
#include<vector>
#include<algorithm>
#include<cmath>
using namespace std;
struct person{	int arrive, serve, p, vip;}temp;
struct node{int end, cnt, vip;};
vector<person> player;
vector<node> table;
void alloctable(int i, int idx){
	if(player[i].arrive <= table[idx].end)	player[i].serve = table[idx].end;
	else	player[i].serve = player[i].arrive;
	table[idx].end = player[i].serve + player[i].p;
	table[idx].cnt++;
}
int findvip(int vip){
	vip++;
	while(vip < player.size() && !player[vip].vip)	vip++;
	return vip;
}
bool cmp1(person a, person b){return a.arrive < b.arrive;};
bool cmp2(person a, person b){return a.serve < b.serve;};
int main(){
	int n, k, m, hh, mm, ss;
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		scanf("%d:%d:%d %d %d", &hh, &mm, &ss, &temp.p, &temp.vip);
		temp.arrive = hh * 3600 + mm * 60 +ss;
		if(temp.arrive >= 21 * 3600)	continue;
		temp.p = temp.p > 120? 2 * 3600 : temp.p * 60;
		temp.serve = 21 * 3600;
		player.push_back(temp); 
	}
	scanf("%d%d", &k, &m);
	table.resize(k + 1);
	for(int i = 0; i < m; ++i){
		int viptable;
		scanf("%d", &viptable);
		table[viptable].vip = 1;
	}
	sort(player.begin(), player.end(), cmp1);
	int i = 0, nextvip = -1; 
	nextvip = findvip(nextvip);
	while(i < player.size()){
		int idx = 1;
		for(int j = 2; j < table.size(); ++j)
			if(table[idx].end > table[j].end)	idx = j;
		if(table[idx].end >= 21 * 3600)	break;
		if(player[i].vip && i < nextvip){
			i++;
			continue;
		}
		if(table[idx].vip){
			if(player[i].vip){
				alloctable(i, idx);
				if(i == nextvip)	nextvip = findvip(nextvip);
				i++;
			} else{
				if(nextvip < player.size() && player[nextvip].arrive <= table[idx].end){
					alloctable(nextvip, idx);
					nextvip = findvip(nextvip);
				}else{
					alloctable(i, idx);
					i++;
				}
			}
		}else{
			if(player[i].vip){
				int viptable = -1, minv = 0x7fffffff;
				for(int j = 1; j < table.size(); ++j)
					if(table[j].vip && table[j].end < minv)	viptable = j, minv = table[j].end;
				if(viptable != -1 && player[i].arrive >= table[viptable].end){
					alloctable(i,viptable);
					if(i == nextvip)	nextvip = findvip(nextvip);
					i++;
				}else{
					alloctable(i, idx);
					if(i == nextvip)	nextvip = findvip(nextvip);
					i++;
				}
			}else{
				alloctable(i, idx);
				i++;
			}
		}
	}
	sort(player.begin(), player.end(), cmp2);
	for(int i = 0; i < player.size() && player[i].serve < 21 * 3600; ++i){
		int arrive = player[i].arrive, serve = player[i].serve, wait = serve - arrive;
		printf("%02d:%02d:%02d %02d:%02d:%02d %0.f\n", arrive / 3600, arrive % 3600 / 60, arrive % 60,
		serve / 3600, serve % 3600 / 60, serve % 60, round(wait / 60.0));
	}
	for(int i = 1; i < table.size(); ++i)
		printf("%d%c", table[i].cnt, i != table.size() - 1?' ': '\n');
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值