PAT甲级1037 Magic Coupon (25 分)

1037 Magic Coupon (25 )

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1NC,NP105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题目大意:

     给出Nc 个折扣券和Np个商品,询问能获得最大的价值是多少,且分正负。而价值是折扣券与商品的乘积。

 

 

思路:

     贪心算法:两个最大相乘定是最大的且当均小于零时两个最小相乘也为最大的。倘若出现一正一负,则必然不可取(因乘积一定小于零)

     那么分开两个数组存储,排好序后按照贪心思想进行操作即可。

 

    

参考代码:

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int> cp, pt;
int main(){
	int n;
	scanf("%d", &n);
	cp.resize(n); 
	for(int i = 0; i < n; ++i)	scanf("%d", &cp[i]);
	scanf("%d", &n);
	pt.resize(n);
	for(int i = 0; i < n; ++i)	scanf("%d", &pt[i]);
	sort(cp.begin(), cp.end()), sort(pt.begin(),pt.end());
	int i = cp.size() - 1, j = pt.size() - 1, total = 0;
	while(i >= 0 && j >= 0){
		if(cp[i] < 0 || pt[j] < 0)	break;
		total += cp[i--] * pt[j--];
	}
	int u =0, v = 0;
	while(u < i && v < j){
		if(cp[u] < 0 && pt[v] < 0)	total += cp[u++] * pt[v++];
		else break;
	}
	printf("%d", total);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值