1048 Find Coins (25 分)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1+V2=M and V1≤V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution
instead.
Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution
题目大意:
给出n枚硬币以及要付的金额m,试图找出两枚硬币刚好能付款。如果没有则输出No Solution。如果方式不唯一则输出数额最小的那一对。
思路:
用双指针法, 录入硬币后将数组排成升序序列,从第一枚开始枚举,如果第一枚加最后一枚(最大的),大于数值m,需要调小一点,即将尾指针减一以获得较小的硬币。直到发现小于m了,则将头指针加一以获得较大的硬币。
参考代码:
1048 Find Coins (25 分)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1+V2=M and V1≤V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution
instead.
Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution
题目大意:
给出n枚硬币以及要付的金额m,试图找出两枚硬币刚好能付款。如果没有则输出No Solution。如果方式不唯一则输出数额最小的那一对。
思路:
用双指针法, 录入硬币后将数组排成升序序列,从第一枚开始枚举,如果第一枚加最后一枚(最大的),大于数值m,需要调小一点,即将尾指针减一以获得较小的硬币。直到发现小于m了,则将头指针加一以获得较大的硬币。
参考代码:
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int n, m;
vector<int> coins;
int main(){
scanf("%d%d", &n, &m);
coins.resize(n);
for(int i = 0; i < n; ++i) scanf("%d", &coins[i]);
sort(coins.begin(), coins.end());
int i = 0, j = n - 1;
while(i < j)
if(coins[i] + coins[j] > m) j--;
else if (coins[i] + coins[j] == m) break;
else i++;
if(i < j) printf("%d %d", coins[i], coins[j]);
else printf("No Solution");
return 0;
}