PAT甲级1066 Root of AVL Tree (25 分)

1066 Root of AVL Tree (25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5

88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7

88 70 61 96 120 90 65

Sample Output 2:

88

      题目大意:

         给出n为长度的一个序列,求平衡二叉树的根节点。

 

思路:

         实质在考察LR操作与平衡二叉树建树。

 

参考代码:

 

#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
	int v;
	node *l , *r;
};
int getH(node * root){
	if(root == NULL)	return 0;
	return max(getH(root->l), getH(root->r)) + 1;
}
void L(node * & root){
	node * temp = root->r;
	root->r = temp->l;
	temp->l = root;
	root = temp;
}
void R(node * & root){
	node * temp = root->l;
	root->l = temp->r;
	temp->r = root;
	root = temp;
}
void LR(node * &root){
	L(root->l), R(root);
}
void RL(node * &root){
	R(root->r), L(root);
}
void insert(node * & root , int v){
	if(root == NULL){
		node * temp = new node;
		temp->v = v;
		temp->r = temp->l = NULL;
		root = temp;
	} else if(v < root->v){
		insert(root->l, v);
		if(getH(root->l) - getH(root->r) == 2)	v < root->l->v? R(root): LR(root);
	} else{
		insert(root->r, v);
		if(getH(root->l) - getH(root->r) == -2)	v < root->r->v? RL(root) : L(root);
	}
}
int main(){
	int n, temp;
	scanf("%d", &n);
	node * root = NULL; 
	for(int i = 0; i < n; ++i){
		scanf("%d", &temp);
		insert(root, temp);
	}
	printf("%d", root->v);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值