PAT甲级1084 Broken Keyboard (20 分)

1084 Broken Keyboard (20 )

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

      题目大意:

         给出一串原本要输入的字符串,再给出实际上屏幕显示的字符串,请问哪些按键坏了?

 

思路:

         盯着要输出的要素,是两个字符串中串1有而串2没有的字符。而且由于可能重复出现同一个坏键现象,那么要设置一个数组,判定为第一次出现的时候才输出该坏键。并且题目有隐含条件,要求按照串1的顺序去找坏键。

 

参考代码:

 

 

#include<string>
#include<cctype>
#include<vector>
#include<iostream>
using namespace std;
string s1, s2;
vector<bool> done(128);
int main(){
	cin >> s1 >> s2;
	for(int i = 0; i <s2.size(); ++i)
		if(islower(s2[i]))	s2[i] = toupper(s2[i]);
	for(int i = 0; i < s1.size(); ++i){
		if(islower(s1[i]))	s1[i] = toupper(s1[i]);
		if(s2.find(s1[i]) == -1 && !done[s1[i]])	printf("%c", s1[i]), done[s1[i]] = true;	
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值