PAT甲级1101 Quick Sort (25 分)

1101 Quick Sort (25 )

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5

1 3 2 4 5

Sample Output:

3

1 4 5

 

      题目大意:

         给出长度为n 的一个序列,请问有多少个数可以当做快排的轴。快排的轴左边的数均小于他,右边的数均大于他。升序输出所有轴。

 

 

思路:

         每次记录该位上左边最大的数与右边最小的数,每向后移动时就要判断右边最小的数是不是他如果是则更新右边最小的数;多了一位后,左边的这个数是否大于当前记录的最大的左边数,如果是则更新他。

         基于此思想,如果直接使用的话,会超时,因为可以知道有不少次是重复计算的。此时灵活运用打表思想就可以解决了, lmax[]、 rmin[]分别记录。参考A1093, 也是同样的思想。

         特别注意,测试点2中,是没有任何一个元素满足条件的,在第二行中要输出一个回车符。

 

参考代码:

 

 

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int> list, ans, lmax, rmin;
int n;
int main(){
	scanf("%d", &n);
	list.resize(n), lmax.resize(n), rmin.resize(n);
	fill(rmin.begin(), rmin.end(), 0x7fffffff);
	for(int i = 0; i < n; ++i)	scanf("%d", &list[i]);
	for(int i = 1; i < n; ++i){
		lmax[i] = max(lmax[i - 1], list[i - 1]);
		rmin[n - 1 - i] = min(rmin[n - i], list[n - i]);
	}
	for(int i = 0; i < n; ++i)
		if(lmax[i] < list[i] && rmin[i] > list[i]) ans.push_back(list[i]);
	sort(ans.begin(), ans.end());
	if(ans.size() == 0){
		printf("0\n\n");
		return 0;
	}
	printf("%d\n%d", ans.size(), ans[0]);
	for(int i = 1; i < ans.size(); ++i)	printf(" %d", ans[i]);
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值