PAT甲级1103 Integer Factorization (30 分)

1103 Integer Factorization (30 )

The KP factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the KPfactorization of N for any positive integers NK and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (400), K (N) and P (1<P7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122+42+22+22+12, or 112+62+22+22+22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1,a2,,aK } is said to be largerthan { b1,b2,,bK } if there exists 1LK such that ai=bi for i<L and aL>bL.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

 

      题目大意:

         给出n、 k 、p , 要求找出n 的k个p次方的因子。如果答案不唯一找到所有因子和最大的若仍不唯一找到最大的序列。

 

 

思路:

         此题与普通的因子分解式不同,采用的是dfs + 剪枝。

         前期准备,进行dfs的条件必须是存在一个可以编号移动的数组,即用v[],存储满足i^p次方小于n的数。接下来对于dfs进行描述:

         查看题目,①要有k个,②要总和等于n,③最大的因子和;补上④编号位移,那么需要4个形参不言而喻。分别用tempk,tempn,tempsum,idx表示。每当满足了有k个则进行判断,如果tempn == n && tempsum > maxsum 就令ans = tempans, maxsum = tempsum。

参考代码:

 

 

#include<cstdio>
#include<cmath>
#include<vector>
using namespace std;
vector<int> tempans, ans, v;
int n, k, p;
int maxsum;
void dfs(int tempk, int tempn, int tempsum, int idx){
	if(tempk == k){
		if(tempn == n && tempsum > maxsum)	ans = tempans, maxsum = tempsum;
		return ;
	}
	while(idx >= 1){
		if(tempn + v[idx] <= n){
			tempans[tempk] = idx;
			dfs(tempk + 1, tempn + v[idx], tempsum + idx, idx);
		}
		if(idx == 1)	return;
		idx--;
	}
} 
int main(){
	scanf("%d%d%d", &n, &k, &p);
	tempans.resize(k);
	int temp = 0, i = 1;
	while(temp <= n){
		v.push_back(temp);
		temp = pow(i, p);
		i++;
	}
	dfs(0, 0, 0, v.size() - 1);
	if(ans.size() == 0){
		printf("Impossible");
		return 0;
	}
	printf("%d = %d^%d", n, ans[0], p);
	for(int i = 1; i < ans.size(); ++i)
		printf(" + %d^%d", ans[i], p);
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/52493390

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值