PAT (Advanced Level) Practice 1155 Heap Paths (30分) (递归+数组建树,递归+vector输出,make_heap判断)

1.题目

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

2.题目分析

1.建树

开始思路跑偏了,一直想着数据结构题库里那个层序遍历输出的题,忘了数据结构老师说过:

完全二叉树按照数组存放的时候,2*i是左子树,2*i+1是右子树 (失败……)

2.输出

vector记录之前的数据,观察发现是遍历(后序遍历)到叶子节点的时候就输出一次,输出后将最后一个删除,再接着遍历 

3.判断

分别使用make_heap建立大根堆、小根堆,以此判断就行

3.代码

#include<iostream>
#include<algorithm>
#include<functional>
#include<vector>
#include<cstdio>
using namespace std;
int list[1001];
typedef struct node * tree;
struct node
{
	int data;
	tree left;
	tree right;
};
tree creat(tree origin,int list[],int i,int n)
{
	if (i > n)return NULL;
	if(!origin)
	origin = (tree)malloc(sizeof(struct node));
	origin->left = origin->right = NULL;
	origin->data = list[i];
	origin->left = creat(origin->left, list, 2 * i,n);
	origin->right = creat(origin->right, list, 2 * i+1, n);
	return origin;
}
void output(tree origin, vector<int>out)
{
	if (!origin)return;
	if (origin->left==NULL&&origin->right==NULL)
	{
		out.push_back(origin->data);
		int size = out.size();
		for (int i = 0; i < size; i++)
			printf("%d%s", out[i], i == size - 1 ? "" : " ");
		printf("\n");
		out.pop_back();
		return;
	}
	out.push_back(origin->data);
    
	output(origin->right, out);
	
	output(origin->left, out);
}
int main()
{
	int n,count=1;
	cin >> n;
	tree origin = (tree)malloc(sizeof(struct node));
	origin->left = origin->right = NULL;
	for (int i = 1; i <=n; i++)
		cin >> list[i];

	origin = creat(origin, list, 1, n);
	vector<int>out;
	output(origin, out);
	vector<int>com;
	for (int i = 1; i <=n; i++)
		com.push_back(list[i]);
	bool big = true;
	make_heap(com.begin(), com.end(), less<int>());
	for (int i = 1; i <= n; i++)
	{
		if (list[i] != com[i - 1]) { big = false; break; }
	}
	if (!big)
	{
		make_heap(com.begin(), com.end(), greater<int>());
		for (int i = 1; i <= n; i++)
		{
			if (list[i] != com[i - 1]) { printf("Not Heap\n"); return 0; }
		}
		printf("Min Heap\n");
	}
	else
		printf("Max Heap\n");
}

甲级加油!💪💪💪

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
make_heap、push_heap、pop_heap和sort_heap都是C++ STL库中的算法,用于操作堆(heap)数据结构。 1. make_heap:将一个无序的区间转换为堆。函数原型如下: ``` template <class RandomAccessIterator> void make_heap (RandomAccessIterator first, RandomAccessIterator last); ``` 其中,first和last别为区间的起始和结束迭代器。make_heap函数会将[first,last)区间转换为堆。调用该函数后,该区间的最大元素会被放在第一个位置上。 2. push_heap:将一个元素添加到堆中。函数原型如下: ``` template <class RandomAccessIterator> void push_heap (RandomAccessIterator first, RandomAccessIterator last); ``` 其中,first和last别为区间的起始和结束迭代器。当前,[first,last-1)已经是一个堆,push_heap函数将last-1位置的元素添加到堆中,并且保证该堆仍然是一个堆。 3. pop_heap:将堆的最大元素移动到末尾。函数原型如下: ``` template <class RandomAccessIterator> void pop_heap (RandomAccessIterator first, RandomAccessIterator last); ``` 其中,first和last别为区间的起始和结束迭代器。当前,[first,last)已经是一个堆,pop_heap函数将该堆的最大元素(即first位置的元素)移动到last-1位置,并且保证[first,last-1)仍然是一个堆。 4. sort_heap:将一个堆排序。函数原型如下: ``` template <class RandomAccessIterator> void sort_heap (RandomAccessIterator first, RandomAccessIterator last); ``` 其中,first和last别为区间的起始和结束迭代器。当前,[first,last)已经是一个堆,sort_heap函数会将该堆转换为有序序列。 需要注意的是,这几个函数都要求操作的区间是一个随机访问迭代器(RandomAccessIterator)类型的迭代器。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值