Longest Ordered Subsequence

http://poj.org/problem?id=2533

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

最长上升子序列问题

第一种方法:

根据dp思想,假如一个序列中只有一个元素,那么它的最长上升子序列就是它本身。一个序列date[k](k为一个序列中第k个元素),只考虑date[k]这一个元素,那么它的状态为dp[k]=1(dp[ ] 这一数组代表的是状态,这里它的状态即为子序列的长度),如果考虑之前的date[k-1]这一元素,则若date[k-1]<date[k],那么dp[k]=2;具体程序如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
//LIS
//dp think
//dp[] store the subsequence length
int date[2000];
int dp[1050];
int n;
int LIS()
{
    int i,j;
    int max,anw;
    dp[0]=1;
    max=0;
    anw=1;
    for(i=1;i<n;++i)
    {
        max=0;
        for(j=0;j<i;++j)
        {
            if(date[j]<date[i]&&dp[j]>max)
            max=dp[j];
        }
        dp[i]=max+1;
        if(anw<dp[i])
        {
            anw=dp[i];
        }
    }
    return anw;
}
int main()
{
    int i;
    cin>>n;
    for(i=0;i<n;++i)
    {
        cin>>date[i];
    }
    printf("%d\n",LIS());
    return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值