Rails (栈)

https://vjudge.net/contest/240386#problem/C

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station
was built in last century. Unfortunately, funds were extremely limited that time. It was possible to
establish only a surface track. Moreover, it turned out that the station could be only a dead-end one
(see picture) and due to lack of available space it could have only one track.
The local tradition is that every train arriving from the direction A continues in the direction
B with coaches reorganized in some way. Assume that the train arriving from the direction A has
N ≤ 1000 coaches numbered in increasing order 1,2,...,N. The chief for train reorganizations must
know whether it is possible to marshal coaches continuing in the direction B so that their order will
be a 1 .a 2 ,...,a N . Help him and write a program that decides whether it is possible to get the required
order of coaches. You can assume that single coaches can be disconnected from the train before they
enter the station and that they can move themselves until they are on the track in the direction B. You
can also suppose that at any time there can be located as many coaches as necessary in the station.
But once a coach has entered the station it cannot return to the track in the direction A and also once
it has left the station in the direction B it cannot return back to the station.


Input
The input file consists of blocks of lines. Each block except the last describes one train and possibly
more requirements for its reorganization. In the first line of the block there is the integer N described
above. In each of the next lines of the block there is a permutation of 1,2,...,N. The last line of the
block contains just ‘0’.
The last block consists of just one line containing ‘0’.
Output
The output file contains the lines corresponding to the lines with permutations in the input file. A line
of the output file contains ‘Yes’ if it is possible to marshal the coaches in the order required on the
corresponding line of the input file. Otherwise it contains ‘No’. In addition, there is one empty line after
the lines corresponding to one block of the input file. There is no line in the output file corresponding
to the last “null” block of the input file.
Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output
Yes
No
Yes

 

正确的想法是每次每一辆火车进站后,比较栈顶元素与出站元素相等不相等,相等时让栈顶元素出栈,同时还应判断此时的栈是否为空,如果为空,让下一辆火车进站,如果不空,继续比较

自己写的错误程序(WA):

由于只用了一个循环,错误在于没有办法在合适的时候终止循环;

正确的程序就应该让当火车进站时,如果栈不空并且栈顶元素可以出栈就始终循环(不让下一辆火进站),不满足这两个条件时才让下一辆火车进站;

主要还是模拟;

#include <iostream>
#include <string>
#include <stdio.h>
#include <algorithm>
#include <set>
#include <stack>

using namespace std;

stack<int> sta;
int N;
int a[10000];

int main()
{
    int i=0,c=0,k=1,j;

    while(~scanf("%d",&N))
    {
        if(N==0) break;

        while(1)
        {
            c=0;
            for(i=1;i<=N;++i)
            {
                scanf("%d",&a[i]);
                if(a[1]==0){c=1; break;}
            }
            if(c) break;

            k=1;
            i=2;
            sta.push(1);
            while(1)
            {
                if(sta.top()==a[k++])
                {
                    sta.pop();
                    if(!sta.empty()) continue;
                }
                if(i<=N) sta.push(i++);
                if(k>N&&sta.empty()) break;
                if(k<N&&i>N&&sta.size()>1) break;
            }

            if(sta.empty()) printf("YES\n");
            else printf("NO %d\n",sta.top());

            while(!sta.empty())
                sta.pop();
        }

        printf("\n");
    }

    return 0;
}

 

改正后的程序(AC):

#include <iostream>
#include <string>
#include <stdio.h>
#include <algorithm>
#include <set>
#include <stack>

using namespace std;

stack<int> sta;
int N;
int a[10000];

int main()
{
    int i=0,c=0,k=1,j;

    while(~scanf("%d",&N))
    {
        if(N==0) break;

        while(1)
        {
            c=0;
            for(i=1;i<=N;++i)
            {
                scanf("%d",&a[i]);
                if(a[1]==0){c=1; break;}
            }
            if(c) break;


            k=1;
            for(i=1;i<=N;++i)
            {
                sta.push(i);
                while(1)
                {
                    if(!sta.empty()&&sta.top()==a[k]) sta.pop(),k++;
                    else break;
                }
            }

            if(sta.empty()) printf("Yes\n");
            else printf("No\n");

            while(!sta.empty())
                sta.pop();
        }
        printf("\n");
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值