HDUoj 1002A+B Problem II——大数

杭电oj 1002 A+B Problem II

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 520232 Accepted Submission(s): 99532

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

这道题因为数据很大,用整数相加不能完成,因此我们可以使用字符串来辅助完成。注意数的前导0需要处理,例如00001+999如果不处理结果会是01000

#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int T;
	int a[1001],b[1001],sum[1001],c=0;
	string a1,b1;
	cin>>T;
	while(T--)
	{
		c++;
		for(int i=0;i<1001;i++)
			a[i]=b[i]=sum[i]=0;
		cin>>a1>>b1;
		int lena=a1.length();
		int lenb=b1.length();
		for(int i=lena-1;i>=0;i--)
			a[lena-1-i]=a1[i]-'0';
		for(int i=lenb-1;i>=0;i--)
			b[lenb-1-i]=b1[i]-'0';
		for(int i=lena-1;i>=0;i--)//去a的前导0 
		{
			if(a[i]==0 && lena>1)
				lena--;
			else
			    break;
		}
		for(int i=lenb-1;i>=0;i--)//去b的前导0 
		{
			if(b[i]==0 && lenb>1)
				lenb--;
			else
			    break;
		}
		int maxlen=max(lena,lenb);
		int carry=(a[0]+b[0])>9 ? 1:0;//有进位则carry为1,否则为0 
		sum[0]=(a[0]+b[0])%10;//个位是第一个产生进位的位置,因此不用加上进位 
		for(int i=1;i<maxlen;i++)//个位以后都要加上进位 
		{
			sum[i]=(a[i]+b[i]+carry)%10;
			carry=(a[i]+b[i]+carry)>9 ? 1:0;
		}
		if(carry==1)
		//如果最高位有进位,则最高位的后一位要加1,即置为1 
		{
			sum[maxlen]=1;
			cout<<"Case "<<c<<":"<<endl;
			cout<<a1<<" + "<<b1<<" = ";
			for(int i=maxlen;i>=0;i--)//因为数是倒着存入数组的,因此要倒着输出数据 
			{
				cout<<sum[i];
			}
			cout<<endl;
		}
		else
		//如果最高位没进位,则最高位后一位不用处理 
		{
			cout<<"Case "<<c<<":"<<endl;
			cout<<a1<<" + "<<b1<<" = ";
			for(int i=maxlen-1;i>=0;i--)
			{
				cout<<sum[i];
			}
			cout<<endl;
		}
		if(T>=1)
		   cout<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值