Free Candies

https://vjudge.net/contest/315672#problem/D

Little Bob is playing a game. He wants to win some candies in it - as many as possible.

There are 4 piles, each pile contains N candies. Bob is given a basket which can hold at most 5 candies. Each time, he puts a candy at the top of one pile into the basket, and if there're two candies of the same color in it ,he can take both of them outside the basket and put them into his own pocket. When the basket is full and there are no two candies of the same color, the game ends. If the game is played perfectly, the game will end with no candies left in the piles.

For example, Bob may play this game like this (N=5):

Step1    Initial Piles    Step2    Take one from pile #2
Piles    Basket    Pocket    Piles    Basket    Pocket
1 2 3 4
1 5 6 7
2 3 3 3
4 9 8 6
8 7 2 1
nothing    nothing    
1 3 4
1 5 6 7
2 3 3 3
4 9 8 6
8 7 2 1
2    nothing
Step3    Take one from pile #2    Step4    Take one from pile #3
Piles    Basket    Pocket    Piles    Basket    Pocket
1 3 4
1 6 7
2 3 3 3
4 9 8 6
8 7 2 1
2 5    nothing    
1 4
1 6 7
2 3 3 3
4 9 8 6
8 7 2 1
2 3 5    nothing
Step5    Take one from pile #2    Step6    put two candies into his pocket
Piles    Basket    Pocket    Piles    Basket    Pocket
1 4
1 6 7
2 3 3
4 9 8 6
8 7 2 1
2 3 3 5    nothing    
1 4
1 6 7
2 3 3
4 9 8 6
8 7 2 1
2 5    a pair of 3
Note that different numbers indicate different colors, there are 20 kinds of colors numbered 1..20.

'Seems so hard...'Bob got very much puzzled. How many pairs of candies could he take home at most?

 

Input

The input will contain no more than 10 test cases. Each test case begins with a line containing a single integer n(1<=n<=40) representing the height of the piles. In the following n lines, each line contains four integers xi1,xi2,xi3,xi4 (in the range 1..20). Each integer indicates the color of the corresponding candy. The test case containing n=0 will terminate the input, you should not give an answer to this case.

 

Output

Output the number of pairs of candies that the cleverest little child can take home. Print your answer in a single line for each test case.

 

Sample Input

5
1 2 3 4
1 5 6 7
2 3 3 3
4 9 8 6
8 7 2 1
1
1 2 3 4
3
1 2 3 4
5 6 7 8
1 2 3 4
0

 

Sample Output

8
0

3

#include<stdio.h>
#include<string.h>
#include<algorithm>
//四维记忆数组dp代表每堆糖果分别被拿了a,b,c,d还能再拿的最大对数 
//d数组记录每堆糖果已经被拿走的糖果数, 
using namespace std;
int a[4][100];//a[i][j],i代表第i堆 ,j代表堆的第j+1个 
int d[4];//d[i]表示第i堆的要取第d[i]+1个 
int vis[100];
int dp[100][100][100][100];
int n;
int dfs(int t)
{
	if(dp[d[0]][d[1]][d[2]][d[3]]!=-1)
	{
		return dp[d[0]][d[1]][d[2]][d[3]];
	}
	else if(t==5)
	{
		return dp[d[0]][d[1]][d[2]][d[3]]=0;
	}
	int ans=0;
	for(int i=0;i<4;i++)
	{
		if(d[i]==n) continue;
		int w=a[i][d[i]];
		d[i]++;
		if(vis[w])
		{
			vis[w]=0;
			ans=max(ans,dfs(t-1)+1);
			vis[w]=1;
		}
		else
		{
			vis[w]=1;
			ans=max(ans,dfs(t+1));
			vis[w]=0;
		}
		d[i]--;
	}
	return dp[d[0]][d[1]][d[2]][d[3]]=ans;
}
int main()
{
	while(scanf("%d",&n)!=EOF&&n)
	{
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<4;j++)
		{
			scanf("%d",&a[j][i]);
		}
	}
	memset(d,0,sizeof(d));
	memset(dp,-1,sizeof(dp));
	memset(vis,0,sizeof(vis));
	printf("%d\n",dfs(0));
    }
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值