PAT甲级-1020-Tree Traversals(二叉树中序、后序转层序)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

思路:

1、后序序列中最后一个元素post[root]即为根
2、根据找到的root将中序序列划分成左右两颗子树
3、对于右子树而言,根为后序中的root-1;对于左子树而言,根为root-(end-i+1)

即:根 - 右子树长度

代码如下

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int N = 31;
struct node{
	int index;int value;
};
bool cmp(node a, node b){
	return a.index < b.index;
}
vector<node> ans;
int post[N],in[N];
void pre(int root,int start,int end,int index)
{
	if(start > end) return;
	int i = start;
	while(i < end &&in[i] != post[root]) i++;
	ans.push_back({index, post[root]});
	pre(root-(end-i+1), start, i-1, 2*index);
	pre(root-1, i+1, end,2*index+1); 
} 
int main()
{
	int n;
	cin>>n;
	for(int i = 1; i <= n; i++) scanf("%d", &post[i]);
	for(int i = 1; i <= n; i++) scanf("%d", &in[i]);
	pre(n, 1, n, 1);
	sort(ans.begin(),ans.end(),cmp);
	for(int i = 0; i < ans.size()-1; i++){
		cout<<ans[i].value<<" ";
	}
	cout<<ans[ans.size()-1].value;
	return 0; 
}
  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值