PAT甲级-1033-To Fill or Not to Fill(贪心+图解)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; Davg(≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i , the unit gas price, and D
​i(≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00
1、贪心过程:

在这里插入图片描述
先按距离排序,每次在可达范围内贪心地找比当前油价还低的加油站,加油使得油量刚好能到该加油站;如果不存在比当前油价还低的加油站,则加满油,到下一个具有lowest price(次便宜)的加油站)。
加满油能行驶的最大距离是600
1、0+600(600)范围内,7.00比当前油价还低,加油使得油量刚好能到该加油站,一滴不浪费
2、150+600(750)范围内,6.85比当前油价还低,加油使得油量刚好能到该加油站,一滴不浪费。
3、300+600(900)范围内,没有比当前油价更低的加油站,找剩余最低油价是7.00,因此加满油到它(保证单位油价效益最高)
4、600+600(1200)范围内,没有比当前油价更低的加油站,找剩余最低油价是7.30,因此加满油到它(保证单位油价效益最高)
5、1200-1300范围内,6.00比当前油价还低,加油使得油量刚好能到该加油站,一滴不浪费。
6、最后,由于终点油价为0.00,比当前油价还低,加油使得油量刚好能到终点,一滴不浪费
____________________________________________________________

不可达终点情况:

设置一个flag,标记是否进入以下循环,如果没能进入以下循环就说明到不了终点,因为sta[i].dist-sta[curId].dist>maxDist,意味着就算加满了油也不可达。

for(int i = curId+1; i<=n&&sta[i].dist-sta[curId].dist<=maxDist; i++){//可达 
	flag = 1;
	if(sta[i].price < minPrice){
		minPrice = sta[i].price;
		index = i;
		if(minPrice < sta[curId].price) break;
	}
}
if(!flag) break;

代码如下

#include<iostream>
#include<algorithm>
#include <float.h>
using namespace std;
struct station{
	double price,dist;
}sta[505];
int cmp(station a, station b){
	return a.dist<b.dist; 
}
int main()
{
	int cMax,d,dAve,n;
	cin>>cMax>>d>>dAve>>n;
	for(int i = 0; i < n; i++){
		cin>>sta[i].price>>sta[i].dist;
	}
	sta[n].price=0;sta[n].dist=d;
	sort(sta, sta+n,cmp);
	if(sta[0].dist!=0){
		cout<<"The maximum travel distance = 0.00"<<endl;
	}else{
		int curId = 0;
		double maxDist=cMax*dAve,curTk=0,ans=0;//maxDist表示加满油状态下能走多远 
		while(curId < n){
			double minPrice=DBL_MAX;
			int index = -1,flag = 0;
			for(int i = curId+1; i<=n&&sta[i].dist-sta[curId].dist<=maxDist; i++){//可达 
				flag = 1;
				if(sta[i].price < minPrice){
					minPrice = sta[i].price;
					index = i;
					if(minPrice < sta[curId].price) break;
				}
			}
			if(!flag) break;
			double needTk=(sta[index].dist-sta[curId].dist)/dAve;//到达该加油站需要的油量 
			if(minPrice < sta[curId].price) {//看看是因为什么退出循环的 
				if(curTk < needTk){
					ans += (needTk-curTk)*sta[curId].price;
					curTk = 0;
				}else{
					curTk -= needTk;
				}
			}else{
				ans += (cMax-curTk)*sta[curId].price;
				curTk = cMax - needTk;
			}
			curId = index;
		}
		if(curId == n){
			printf("%.2f\n", ans);
		}else{
			printf("The maximum travel distance = %.2f\n", sta[curId].dist+maxDist);
		}
	}
	return 0;
}
  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值