POJ1330 Nearest Common Ancestors (树类型水题)

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:
参考模型

In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.
For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.
Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge –the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

题目源自网络

题意

给出一个数字n,有从1~n编号的结点,接下来n-1行给出(a, b)形式的数对,表示b的父亲节点是a.再输入一个数对(a, b),求他们最近的祖先节点,即求a和b祖先节点中相同的且离他们长度最小的节点(自己本身也是自己的父亲节点)。

解析

按1~n编号,则开拓数组最大为n,不会超过空间限制,可以用一个数组保存各节点的父亲节点。在求(a,b)最近祖先节点时可以逆序将a和b的全部祖先节点搜索并保存,这样逆序求得的祖先节点就是依次距离长度增加的,届时从最初开始比较即是寻找最近,最后再对比二者第一个相同的祖先节点,就是所求。

#include<iostream>
#include<math.h>
#include <algorithm>
#include<stdio.h>
#include<string.h>
#include<stack> 
#include<queue>
using namespace std;
#define rep(i, a, b) for(int i=(a); i<(b); i++)
#define req(i, a, b) for(int i=(a); i<=(b); i++)
#define ull unsigned __int64
#define sc(t) scanf("%d",&(t))
#define sc2(t,x) scanf("%d%d",&(t),&(x))
#define pr(t) printf("%d\n",(t))
#define pf printf
#define prk printf("\n")
#define pi acos(-1.0)
#define ms(a,b) memset((a),(b),sizeof((a)))
#define mc(a,b) memcpy((a),(b),sizeof((a))) 
#define w while
#define vr vector<int>
typedef long long ll;

int map[10005];
int a[10005];
int b[10005];
int n;

int main()
{
    int x, y;
    int cas;
    sc(cas);
    bool flag;
    w(cas--)
    {
        ms(a, 0);  //初始化
        ms(b, 0);
        ms(map, 0);
        sc(n);
        rep(i, 1, n)
        {
            sc2(x, y);
            map[y] = x; //记录父节点
        } 
        int i = 0, j = 0;
        sc2(x, y);
        a[i++] = x; 
        b[j++] = y;
        w(map[x]) //不为0就表示还未到根节点,继续搜索
        {
            a[i++] = map[x]; //记录父节点
            x = map[x]; //寻找父节点的父节点
        }
        w(map[y]) 
        {
            b[j++] = map[y];
            y = map[y];
        }
        flag = false;
        rep(k, 0, i) //进行比较
        {
            rep(f, 0, j)
            if(a[k] == b[f])
            {
                pr(a[k]);
                flag = true;
                break;
            }
            if(flag)
            break;
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值