codeup————6112(Be unique)(哈希)

问题 C: Be Unique (20)

[命题人 : 外部导入]

时间限制 : 1.000 sec  内存限制 : 32 MB

解决: 908提交: 2010统计

题目描述

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

输入

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

输出

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

样例输入 Copy

7 5 31 5 88 67 88 17
5 888 666 666 888 888

样例输出 Copy

31
None

 

#include<iostream>
using namespace std;

int main(){
	int N;
	while(cin>>N){
		int n[100001]={0},loca[100001]={0},values[100001]={0},nums[100001]={0};
		for(int i=0;i<N;i++){
			cin>>n[i];
			int temp=n[i]%100001;
			if(values[temp]!=0){
				if(values[temp]!=n[i]){
					while(values[temp]!=0){
						if(values[temp]==n[i]){
							break;
						}
						if(temp==100000){
							temp=0;
						}
						else {
							temp++;
						}
					}
				}
			}
			values[temp]=n[i];
			nums[temp]++;
			loca[i]=temp;
		}
		for(int i=0;i<N;i++){
			if(nums[loca[i]]==1){
				cout<<n[i]<<endl;
				break;
			}
			if(i==N-1){
				cout<<"None"<<endl;
			}
		}
	}
	return 0;
} 

今日份总结:哈希——线性探查法

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值