【POJ1151】【Atlantis】

题目:

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity. 

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 

The input file is terminated by a line containing a single 0. Don’t process it.

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 

Output a blank line after each test case. 

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

自己做的第一道扫描线的题目,是看的学长给的题解,才敲出来的,实话,扫描线的原理其实不难,难的是怎么实现它,可能是我的特点吧,有很多题目都是知道思路,却敲不出来。。。。

解题思路:

扫描线基础题,理解原理后,看看代码就差不多了,嘿嘿嘿 

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define maxn 115
using namespace std;
typedef long long ll;
struct edge{
	double l,r;
	double h;
	int f;
}e[maxn<<1];
bool cmp(edge a,edge b)
{
	return a.h<b.h;
} 
struct Node{
	int l,r;
	int s;
	double len;
}q[maxn*8];
double x[maxn<<1];

void build (int l,int r,int cur)
{
	q[cur].l=l;
	q[cur].r=r;
	q[cur].s=0;
	q[cur].len=0;
	if(l==r) return ;
	int mid=(q[cur].l+q[cur].r)>>1;
	build(l,mid,cur<<1);
	build(mid+1,r,cur<<1|1);
}
void pushup(int cur)
{
	if(q[cur].s)
	{
		q[cur].len= x[q[cur].r+1]-x[q[cur].l];
	}
	else
	if(q[cur].l==q[cur].r)
	{
		q[cur].len=0; 	
	}
	else
	{
		q[cur].len=q[cur<<1].len+q[cur<<1|1].len;
	}
}
void updata(int l,int r,int cur,int xx)
{
	if(q[cur].l==l&&q[cur].r==r)
	{
		q[cur].s+=xx;
		pushup(cur);
		return ;
	}
	int mid=(q[cur].l+q[cur].r)>>1;
	if(r<=mid) updata(l,r,cur<<1,xx);
	else if(l>mid) updata(l,r,cur<<1|1,xx);
	else
	{
		updata(l,mid,cur<<1,xx);
		updata(mid+1,r,cur<<1|1,xx);
	}
	pushup(cur);
}
int main()
{
	int n;
	int kase =0;
	while(scanf("%d",&n)&&n)
	{
		int tot=0;
		for(int i=0;i<n;i++)
		{
			double x1,x2,y1,y2;
			scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
			edge t1,t2;
			t1.l=t2.l=x1;
			t1.r=t2.r=x2;
			t1.h=y1;
			t1.f=1;
			t2.h=y2;
			t2.f=-1;
			e[tot]=t1;
			e[tot+1]=t2;
			x[tot]=x1;
			x[tot+1]=x2;
			tot+=2; 
		}
		sort(e,e+tot,cmp);
		sort(x,x+tot);
		int k=1;
		for(int i=1;i<tot;i++)
		{
			if(x[i]!=x[i-1])
			{
				x[k++]=x[i];
			}
		}
		build(0,k-1,1);
		double ans=0.0;
		for(int i=0;i<tot;i++)
		{
			int l=lower_bound(x,x+k,e[i].l)-x;
			int r=lower_bound(x,x+k,e[i].r)-x-1;
			updata(l,r,1,e[i].f);
			ans+=(e[i+1].h-e[i].h)*q[1].len;
		}
		printf("Test case #%d\n",++kase);
		printf("Total explored area: %.2f\n",ans);
		printf("\n");
	}
	return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值