【HDU 3466】【Proud Merchants】

题目:

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more. 
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 
If he had M units of money, what’s the maximum value iSea could get? 
 

Input

There are several test cases in the input. 

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. 

The input terminates by end of file marker. 
 

Output

For each test case, output one integer, indicating maximum value iSea could get. 
 

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output

5
11

解题思路:就是求解在已有的menoy基础上,我们能购买多少价值的东西,且买这个东西必须满足你的金额大于一定数值,就算你的钱能买它,如果达不到那个值,也不能购买。

当看到这道题,惊呆了,什么骚操作,怎么用01背包实现,写的垃圾代码秒wa ,之后参考神犇代码 ,发现居然有以q-p排序这骚操作,当时不明白这是原因,后来思考后发现咱们要满足一个原则,在钱多的时候优先购买我们能买的最有用的东西。

自己说的也是比较含糊不清的,转一下神犇的说法 

https://blog.csdn.net/chen_lin111/article/details/44702389

要想在限制条件下获得最大价值,要满足买了一件物品后尽量使剩下的钱最多,这样尽量满足下一个物品的限制条件!

假如有两个商品:

物品 价格 限制条件

A p1 q1

B p2 q2

1:先买A,至少有 p1 + q2 元钱;先买B,至少有 p2 + q1 元钱。

2:假设先买A需要的钱少,即 p1 + q2 < p2 + q1,也就是 q1 – p1 > q2 – p2。

3:所以,先买 q – p 大的!需要将这些物品按 q – p 升序排列。

4:咦,有人该问了,不是先买差值大的,那怎么升序排列了?这样不就是先买差值小的了!

5:这个我刚开始也是困惑,下面慢慢分析:

看动态转移方程:dp[ j ] = max(dp[ j ], dp[ j - v[ i ] ] + w[ i ]),计算 j 的时候已经将 j – v[ i ] 算出

就是买第一个的时候已经决定了第二个是否买了。这个要自己有耐心地慢慢体会。。。。。。

还有大神说要满足无后效性:j – v[ i ] 定比 j 先算出来,对物品 i 最小能算到q[ i ] – p[ i ],因此以q[ i ] – p[ i ] 排序。个人感觉与上面的分析有异曲同工之妙。

ac代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 10000
using namespace std;

struct nod{
	int p,q,v;
}node[maxn];
int dp[maxn];
bool cmp(nod a,nod b)
{
	return a.q-a.p<b.q-b.p;
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d",&node[i].p,&node[i].q,&node[i].v);
		}
		sort(node,node+n,cmp);
		memset(dp,0,sizeof(dp));
		for(int i=0;i<n;i++)
		{
			for(int j=m;j>=node[i].q;j--)
			{
				dp[j]=max(dp[j],dp[j-node[i].p]+node[i].v);	
			}	
		}
		printf("%d\n",dp[m]);	
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值